Wordpress

Solved Error: commonL10n is not defined (Eklentileri devre dışı bırakmayı denediniz mi?)

By Kasım 25, 2020No Comments

Tarayıcı konsolunda “Uncaught ReferenceError: commonL10n is not defined” olarka görünen bu hata benim sistemimde “Meta Generator and Version Info Remover” isimli eklentiden kaynaklanıyordu. Sanırım bu eklenti WordPress’in önemli bir güncellemesini kaçırmış ve dolayısıyla bir çok sistemde hataya sebebiyet vermiş durumda.

Bu hatanın çözümü için google’da bir çok arama yapabilirsiniz mesela bu tip bir arama yapmayı deneyebilirsiniz ancak bir çok kaynakta functions.php dosyasına eklenmesi gereken bir koddan bahsedecektir ya da hatanın sebebi anlatılacaktır ancak bu hataya sebep olan eklentiyi bulmak tamamen size kalmış durumda. Yapılması gereken en iyi şey eklentileri tek tek devre dışı bırakmak olacaktır. (Eğer bir güvenlik eklentisi ya da url yönlendirmelerinizi yöneten bir eklenti varsa çok dikkatli olun, daha sonra eklentileri aktif etmek zorlanabilirsiniz)

English (with google translate)

This error was caused by the plugin named “Meta Generator and Version Info Remover” on my system. I think this plugin missed an important update of WordPress and thus caused errors in many systems.

For the solution of this error, you can do a lot of searches on google, for example, you can try to do this type of search, but many sources will mention a code that should be added to the functions.php file, or the cause of the error will be explained, but it is entirely up to you to find the plugin that causes this error. The best thing to do is to disable individual plugins. (Be very careful if you have a security plugin or a plugin that manages your url redirects, then you may have difficulty activating plugins)

Leave a Reply